Simple BGP: One ISP, One Router

Configuration Details:
Local ASN – 3000
ISP ASN – 2000
Local Networks – 10.1.1.0/23, 192.168.50.0/22
Cross-Connected Circuit to ISP – 172.16.100.0/32
(ISP Router = 172.16.100.1, Customer Router = 172.16.100.2
Interface = FastEthernet 1/1/1)
interface FastEthernet1/1/1
ip address 172.16.100.2 255.255.255.252
!
router bgp 3000
network 10.1.1.0/23
network 192.168.50.0/22
neighbor 172.16.100.2 remote-as 2000
neighbor 172.16.100.2 soft-reconfiguration inbound
neighbor 172.16.100.2 filter-list 100 out
neighbor 172.16.100.2 next-hop-self
ip as-path access-list 100 permit ^$
ip route 10.1.1.0/23 null0 distance 250
ip route 192.168.50.0/22 null0 distance 250
!